<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
	<meta charset="UTF-8">

	<meta http-equiv="content-type" content="text/html; charset=utf-8" />
	<meta http-equiv="Content-Language" content="en-us" />
	

	<!-- facebook and slack open graph tags -->
	<meta property="og:type" content="website">
	<meta property="og:site_name" content="Furbo.org by Craig Hockenberry">
	<meta property="og:title" content="Software Survival &bull; furbo.org" />
	<meta property="og:description" content="I just finished reading an oddly named book by someone you’ve probably never heard of – I loved it so much I’m writing this site’s first book review. Ken Kocienda is a talented developer. He’s also a lucky one: he worked at Apple during the years when the Mac was reborn and the iPhone was [&hellip;]" />
	<meta property="og:image" content="https://furbo.org/wp-content/uploads/2018/09/Wallabies.jpeg" />

	<!-- twitter card tags -->
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:site" content="@chockenberry">
	<meta name="twitter:title" value="Software Survival &bull; furbo.org" />
	<meta name="twitter:description" value="I just finished reading an oddly named book by someone you’ve probably never heard of – I loved it so much I’m writing this site’s first book review. Ken Kocienda is a talented developer. He’s also a lucky one: he worked at Apple during the years when the Mac was reborn and the iPhone was [&hellip;]" />
	<meta name="twitter:image" content="https://furbo.org/wp-content/uploads/2018/09/Wallabies.jpeg" />
	
	<!-- traditional metadata tags -->
	<meta name="description" content="I just finished reading an oddly named book by someone you’ve probably never heard of – I loved it so much I’m writing this site’s first book review. Ken Kocienda is a talented developer. He’s also a lucky one: he worked at Apple during the years when the Mac was reborn and the iPhone was [&hellip;]" />
	<meta name="keywords" content="CHOCK, design, development, app, user, interface, experience, UI, UX, iconfactory, mobile, Mac, iOS, web, software" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta name="robots" content="NOODP">

	<title>Software Survival &bull; furbo.org</title>
	
	<link rel="alternate" type="application/rss+xml" title="furbo.org News" href="https://furbo.org/feed/" />
<link rel="canonical" href="https://furbo.org/2018/09/04/software-survival/" />
<link rel='shortlink' href='https://furbo.org/?p=2314' />
<link rel="alternate" type="application/json" title="JSON Feed" href="https://furbo.org/feed/json/" />
	<link href="https://furbo.org/wp-content/themes/furbo/reset.css?ver=20150205" media="screen" rel="Stylesheet" type="text/css" />
	<link href="https://furbo.org/wp-content/themes/furbo/style.css?ver=20150206" media="screen" rel="Stylesheet" type="text/css" />

	<link rel="shortcut icon" href="/favicon.ico" />
	<link href="https://micro.blog/chockenberry" rel="me" />
 
	<script type="text/javascript" src="https://furbo.org/wp-content/themes/furbo/scripts/minified.js"></script>
	<script type="text/javascript" src="https://furbo.org/wp-content/themes/furbo/scripts/furbo.js"></script>
	
	<script>
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

		ga('create', 'UA-12748460-3', 'auto');
		ga('send', 'pageview');
	</script>

</head>

<body class="post-template-default single single-post postid-2314 single-format-standard">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
					<p class="site-title screen-reader-text">
				<a href="https://furbo.org/" rel="home">furbo.org</a>
			</p>
		
		<div id="logo">
			<a href="https://furbo.org/" rel="home">
				furbo.org			</a>
		</div>
		<div id="collapsed-logo">
			<a href="https://furbo.org/" rel="home">
				furbo.org			</a>
		</div>
		<div id="controls">
			<p id="control-info" onclick="toggleSidebar();">info</p>
		</div>
	</header><!-- .site-header -->

	<div id="background">
	</div>

	<div id="sidebar" class="sidebar">
			<div id="secondary" class="secondary">

		<aside id="about-me" class="widget widget_text">
			<h2 class="widget-title">About Me</h2>
			<div class="textwidget">
				<p>
					I'm Craig Hockenberry and this is where I write for the web. I make <a href="https://iconfactoryapps.com">apps</a> and run <a href="https://iconfactory.com">websites</a>.
				</p>
				<p>
					You can learn <a href="/about">more about me</a>, view <a href="/resume">my résumé</a>, or  <a href="https://twitter.com/chockenberry">follow me</a>.
				</p>
			</div>
		</aside>
		
					<div id="widget-area" class="widget-area" role="complementary">
				<aside id="search-3" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://furbo.org/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>		<aside id="recent-writing-3" class="widget widget_recent_entries">		<h2 class="widget-title">Recent Writing</h2>		<ul>
					<li>
				<a href="https://furbo.org/2018/09/04/software-survival/">Software Survival</a>
						</li>
					<li>
				<a href="https://furbo.org/2018/07/10/a-tribute-to-ibeer/">A Tribute to iBeer</a>
						</li>
					<li>
				<a href="https://furbo.org/2018/03/28/system-fonts-in-css/">System Fonts in CSS</a>
						</li>
					<li>
				<a href="https://furbo.org/2018/03/06/benchmarking-in-your-pants-10th-anniversary-edition/">Benchmarking in your pants &#8211; 10th Anniversary Edition™</a>
						</li>
					<li>
				<a href="https://furbo.org/2017/12/01/how-not-to-do-accessibility/">How Not to Do Accessibility</a>
						</li>
					<li>
				<a href="https://furbo.org/2017/08/22/luna-display/">Luna Display</a>
						</li>
					<li>
				<a href="https://furbo.org/2017/02/17/swift-changes-considered-harmful/">Swift Changes Considered Harmful</a>
						</li>
					<li>
				<a href="https://furbo.org/2017/01/31/a-new-way-to-work/">A New Way to Work</a>
						</li>
					<li>
				<a href="https://furbo.org/2016/12/09/making-sense-of-color-management/">Making Sense of Color Management</a>
						</li>
					<li>
				<a href="https://furbo.org/2016/11/05/apples-lenovo/">Apple&#8217;s Lenovo</a>
						</li>
				</ul>
		</aside><aside id="history-2" class="widget widget_archive"><h2 class="widget-title">Archives</h2>		<ul>
			<li><a href='https://furbo.org/2018/'>2018</a></li>
	<li><a href='https://furbo.org/2017/'>2017</a></li>
	<li><a href='https://furbo.org/2016/'>2016</a></li>
	<li><a href='https://furbo.org/2015/'>2015</a></li>
	<li><a href='https://furbo.org/2014/'>2014</a></li>
	<li><a href='https://furbo.org/2013/'>2013</a></li>
	<li><a href='https://furbo.org/2012/'>2012</a></li>
	<li><a href='https://furbo.org/2011/'>2011</a></li>
	<li><a href='https://furbo.org/2010/'>2010</a></li>
	<li><a href='https://furbo.org/2009/'>2009</a></li>
	<li><a href='https://furbo.org/2008/'>2008</a></li>
	<li><a href='https://furbo.org/2007/'>2007</a></li>
		</ul>
</aside>			</div><!-- .widget-area -->
		
		<aside id="other" class="widget widget_text">
			<div class="textwidget">
				<p>
					RSS in <a href="https://furbo.org/feed">XML</a> or <a href="https://furbo.org/feed/json">JSON</a>
				</p>
				<p>
					&copy; 2018 Craig Hockenberry
				</p>
				<p>
					All rights reserved
				</p>
			</div>
		</aside>

	</div><!-- .secondary -->

	</div><!-- .sidebar -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-2314" class="post-2314 post type-post status-publish format-standard hentry category-design category-development">

	<div class="entry-header">
		<h1 class="entry-title">Software Survival</h1>	</div><!-- .entry-header -->

	<div class="entry-content">
		<p>I just finished reading an oddly named book by someone you’ve probably never heard of – I loved it so much I’m writing this site’s first book review. </p>
<p><a href="https://twitter.com/kocienda">Ken Kocienda</a> is a talented developer. He’s also a lucky one: he worked at Apple during the years when the Mac was reborn and the iPhone was created.</p>
<p>If you’ve ever opened the web browser in your pocket or typed a text message on a piece of glass, you’ve used his seminal work. Ken was directly responsible for two important parts of the original iPhone: a fast and efficient web framework and a keyboard that was both virtual and predictive.</p>
<p>Ken is also a great storyteller. His experiences during these formative years provide great material for this narrative. But more importantly, he extracts lessons from these tales that can be applied to our own efforts.</p>
<p>In short, <em><a href="http://creativeselection.io">Creative Selection</a></em> is a study on how great products evolve that inspires the reader.</p>
<hr />
<p>I first learned of Ken’s work during a presentation at WWDC 2014. <em><a href="https://developer.apple.com/videos/play/wwdc2014/237/">A Strategy for Great Work</a></em> showed that in addition to doing interesting things, he also took the time for introspection and learning from the work. I immediately followed him on Twitter and eventually discovered our mutual admiration! (That, in turn, led to the advanced copy I’m reviewing today.)</p>
<p>This talk, along with the ones that <a href="https://developer.apple.com/videos/play/wwdc2011/112/">preceded</a> <a href="https://developer.apple.com/videos/play/wwdc2012/212/">it</a>, feel like a formative process for the chapters of the book. The video linked above will give you a very good idea for the tone of his latest work, but there’s also an important difference.</p>
<p>Ken no longer works at Apple.</p>
<p>The end of presentation in 2014 alludes to this situation: not being able to talk about certain things is a fact of life in Cupertino. </p>
<p>I found Ken’s new freedom most intriguing when he focused on other people’s contributions to the secret projects. Every developer knows that a success involves many different talents and personalities. And with Apple’s penchant for secrecy, we never hear about these team interactions.</p>
<hr />
<p>The collaboration between Steve Jobs and Jony Ive is not only well known, it’s well understood. I think this is because industrial design is much more concrete and easier to interpret in the formative stages.</p>
<p>Steve had another important collaborator, but that relationship isn’t as well understood. Creating software requires abstract decisions and a more opaque process. How do you make a button on a piece of glass?</p>
<p>When you look at the Wallabies from Ken’s desk, you can see where the hardware is headed:</p>
<p><a href="https://twitter.com/kocienda/status/880451736049139712"><img src="https://furbo.org/wp-content/uploads/2018/09/Wallabies.jpeg" alt="iPhone Prototypes from Ken Kocienda&#039;s desk." width="1600" height="1240" class="aligncenter size-full wp-image-2317" /></a></p>
<p>When you think about what was on those screens, things get more complicated.</p>
<p>This book changed my view of Scott Forstall because it gave context to his work. Ken’s account breaks down the approach and shows how important Scott’s leadership was to Apple’s success. </p>
<p>Having Steve Jobs as a boss for your entire professional career would not be easy, but Scott handled it with great success. Even when that powerful mentor was asking for skeuomorphism.</p>
<p>The hardware would be lesser without Jony, and Ken shows that the software would be lesser without Scott.</p>
<hr />
<p>If you’re a developer, you’ll find some passages a little slow going. That’s because you know too much :-)</p>
<p>As a great storyteller, Ken endeavors to make the topic as widely understood as possible. To achieve this he turns to analogies in cooking, sports, and the movies while describing the process of creating software.</p>
<p>While we may not need this high-level view, there is an important group that will benefit: our families. If you’re like me, you’ve struggled to explain what you do at that keyboard all day.</p>
<p>We all love our iPads and Kindles for reading, but I’m really glad I have <a href="https://amzn.to/2NFBeD9">a printed copy of the book</a> to share with the people I love.</p>
<hr />
<p>I’ve avoided spoilers in this review, but I’ll end with one story that touched me. When asked about the most important thing in development, I always answer with one word: <strong>empathy</strong>. </p>
<p>Ken links this concept, along with the combination of good taste, the philosophy of <a href="https://en.wikipedia.org/wiki/Immanuel_Kant">Immanuel Kant</a>, and a discussion of atoms by <a href="http://www.feynmanlectures.caltech.edu/I_01.html">Richard Feynman</a>, all while explaining the choice of a QWERTY keyboard layout.</p>
<p>These complex factors enable a personal connection between people. Imagine being the developer whose choices led to the ability to send a quick message saying “Just landed.” Informing a loved one of your safe arrival transcends the importance of any line of code.</p>
<p>That is work to be proud of and we’re lucky Ken has taken the time to <a href="https://amzn.to/2NFBeD9">share it</a> with us all.</p>
	</div><!-- .entry-content -->

	<div class="entry-footer">
		Written on September 4th, 2018  for <a href="https://furbo.org/category/design/" rel="category tag">Design</a>, <a href="https://furbo.org/category/development/" rel="category tag">Development</a> 			</div><!-- .entry-footer -->

</article><!-- #post-## -->
			<div id="post-navigation">
				<div class="newer"><a href="https://furbo.org/">Latest</a></div>
			</div>

		</main><!-- .site-main -->
	</div><!-- .content-area -->


	</div><!-- .site-content -->

	<footer id="footer" class="site-footer" role="contentinfo">
		<div class="features">
			<div class="feature">
			<script type="text/javascript">
				var content = [];

				content.push('\
					<a href="https://design.iconfactory.com">\
						<img src="/footer/designsite.png" width="198" height="101" />\
					</a>\
					<h5>Do you write awesome code?</h5>\
					<p>Of course, you do!</p>\
					<p>But if you\'re like me, you struggle with design and opening Photoshop makes you break out in a cold sweat.</p>\
					<p>\
						<a href="https://design.iconfactory.com">\
						The designers that help me can also help you…</a>\
					</p>\
				');

				content.push('\
					<a href="https://xscopeapp.com">\
						<img src="/footer/xscope4.png" width="198" height="101" />\
					</a>\
					<h5>I made this app because I needed it.</h5>\
					<p>\
						If you do any kind of Web, iOS or Mac development, you need these \
						<a href="https://xscopeapp.com/guide">\
						awesome tools</a>. I did.\
					</p>\
					<p>\
						After a few days with xScope\'s \
						<a href="https://xscopeapp.com">\
						FREE trial</a>, you\'ll wonder how you ever did work without it. Trust me.\
					</p>\
				');
		
				content.push('\
					<a href="https://furbo.org/2014/09/03/the-terminal/">\
						<img src="/footer/terminal.png" width="200" height="100" />\
					</a>\
					<h5>$ sudo rm -rf /</h5>\
					<p>You use this app every day, but do you know what happens when you option click in it?</p>\
					<p>\
						Find out in my magnum opus on \
						<a href="https://furbo.org/2014/09/03/the-terminal/">\
						The Terminal</a>.\
					</p>\
				');

				content.push('\
					<a href="https://itunes.apple.com/us/app/ipulse/id1028916583?ls=1&mt=12&uo=4&at=10l4G7&ct=FURBO_FOOTER">\
						<img src="/footer/ipulse3.png" width="200" height="100" />\
					</a>\
					<h5>What is your Mac doing right now?</h5>\
					<p>If you\'re reading this site, chances are good that you know <em>a lot</em> about your computer.</p>\
					<p>\
						But do you know what\'s going on behind the scenes? \
						<a href="https://itunes.apple.com/us/app/ipulse/id1028916583?ls=1&mt=12&uo=4&at=10l4G7&ct=FURBO_FOOTER">\
						iPulse does</a>.\
					</p>\
				');

				content.push('\
					<a href="https://furbo.org/2015/07/09/i-left-my-system-fonts-in-san-francisco/">\
						<img src="/footer/systemfonts.png" width="200" height="100" />\
					</a>\
					<h5>Where in the world is San Francisco?</h5>\
					<p>Showing Apple\'s lovely new system font on a web page isn\'t easy.</p>\
					<p>\
						Check out my handy guide for \
						<a href="https://furbo.org/2015/07/09/i-left-my-system-fonts-in-san-francisco/">\
						adding San Francisco to your CSS</a>.\
					</p>\
				');

				content.push('\
					<a href="https://twitterrific.com/mac">\
						<img src="/footer/twitterrific5.png" width="200" height="100" />\
					</a>\
					<h5>Twitterrific 5 for macOS</h5>\
					<p>The <a href="https://furbo.org/2013/06/28/the-origin-of-tweet/">world&rsquo;s first Twitter app</a> is back with with an all-new version for macOS.</p>\
					<p>\
						Check out \
						<a href="https://twitterrific.com/mac">\
						Twitterrific.com</a> for all the details.\
					</p>\
				');


				var min = 0;
				var max = content.length - 1;
				var index = Math.floor(Math.random() * (max - min + 1)) + min;
				
				document.write(content[index]);			
			</script>

			</div><!-- .feature -->
		</div><!-- .features -->
	</footer><!-- .site-footer -->

</div><!-- .site -->


</body>
</html>

<!-- Dynamic page generated in 0.045 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2018-09-05 22:34:05 -->

<!-- super cache -->